Resolved: Login Issues via Microsoft Entra SSO
Resolved
Sep 22 at 10:04am EDT
At 12:43 UTC, a user reported they were unable to log in to MentorAPM (Ticket #MST00000549) using Azure SSO (Microsoft Entra). Our team immediately investigated, identified the issue, and restored services by 14:04 UTC. Non-SSO users were unaffected during this time.
The outage was caused by an unexpected expiration of a Microsoft Azure SSO certificate. Once identified, the certificate was replaced and all systems were verified back online across Web and Mobile.
To strengthen safeguards, we’ve added new monitoring and alerts to ensure that certificate issues are detected and addressed more quickly in the future.
We sincerely apologize for the disruption and appreciate your patience while we worked with Microsoft services to restore normal operations.
Affected services